summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-07-11 12:57:30 -0400
committerNick Mathewson <nickm@torproject.org>2018-07-11 13:22:20 -0400
commit79267bad654ed39f13e6fb89a5468f23468c3169 (patch)
tree46be8aac78ff4d0074e749a8b4eb1d050d686b4c /configure.ac
parent92db96d80fddca5394a24256bb6b4691f380a8ae (diff)
downloadtor-79267bad654ed39f13e6fb89a5468f23468c3169.tar.gz
tor-79267bad654ed39f13e6fb89a5468f23468c3169.zip
Add a configure switch to build with NSS.
When it is set, include the NSS headers and libraries as appropriate. Doesn't actually use them yet, though.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 532476672a..2fe353d75d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,6 +53,8 @@ AC_ARG_ENABLE(restart-debugging,
AS_HELP_STRING(--enable-restart-debugging, [Build Tor with support for debugging in-process restart. Developers only.]))
AC_ARG_ENABLE(zstd-advanced-apis,
AS_HELP_STRING(--disable-zstd-advanced-apis, [Build without support for zstd's "static-only" APIs.]))
+AC_ARG_ENABLE(nss,
+ AS_HELP_STRING(--enable-nss, [Use Mozilla's NSS TLS library. (EXPERIMENTAL)]))
if test "x$enable_coverage" != "xyes" -a "x$enable_asserts_in_tests" = "xno" ; then
AC_MSG_ERROR([Can't disable assertions outside of coverage build])
@@ -64,6 +66,15 @@ AM_CONDITIONAL(DISABLE_ASSERTS_IN_UNIT_TESTS, test "x$enable_asserts_in_tests" =
AM_CONDITIONAL(LIBFUZZER_ENABLED, test "x$enable_libfuzzer" = "xyes")
AM_CONDITIONAL(OSS_FUZZ_ENABLED, test "x$enable_oss_fuzz" = "xyes")
AM_CONDITIONAL(USE_RUST, test "x$enable_rust" = "xyes")
+AM_CONDITIONAL(USE_NSS, test "x$enable_nss" = "xyes")
+AM_CONDITIONAL(USE_OPENSSL, true)
+
+if test "x$enable_nss" = "xyes"; then
+ AC_DEFINE(ENABLE_NSS, 1,
+ [Defined if we're building with NSS in addition to OpenSSL.])
+fi
+AC_DEFINE(ENABLE_OPENSSL, 1,
+ [Defined if we're building with OpenSSL or LibreSSL])
if test "$enable_static_tor" = "yes"; then
enable_static_libevent="yes";
@@ -822,6 +833,17 @@ LIBS="$save_LIBS"
AC_SUBST(TOR_LIB_MATH)
dnl ------------------------------------------------------
+dnl Hello, NSS. You're new around here.
+if test "x$enable_nss" = "xyes"; then
+ PKG_CHECK_MODULES(NSS,
+ [nss],
+ [have_nss=yes],
+ [have_nss=no; AC_MSG_ERROR([You asked for NSS but I can't find it.])])
+ AC_SUBST(NSS_CFLAGS)
+ AC_SUBST(NSS_LIBS)
+fi
+
+dnl ------------------------------------------------------
dnl Where do you live, openssl? And how do we call you?
tor_openssl_pkg_redhat="openssl"