summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2016-02-10 15:38:52 -0500
committerNick Mathewson <nickm@torproject.org>2016-02-10 15:38:52 -0500
commit69c47ab5fd608ecd47ddd3c1d2f041a2b41791b5 (patch)
treea0742ef91ea8dde163cfdc60fe359b17a4d1b619 /configure.ac
parent4dc8dc4b89259e1418cd984abe1cd8d8fc6a7496 (diff)
parent55d6fd27cbe6f058a1f444f47f05c7b64891655e (diff)
downloadtor-69c47ab5fd608ecd47ddd3c1d2f041a2b41791b5.tar.gz
tor-69c47ab5fd608ecd47ddd3c1d2f041a2b41791b5.zip
Merge remote-tracking branch 'sebastian/bug18242'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 85fc500964..1d7e11cf62 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,11 +41,19 @@ AC_ARG_ENABLE(unittests,
AS_HELP_STRING(--disable-unittests, [don't build unit tests for Tor. Risky!]))
AC_ARG_ENABLE(coverage,
AS_HELP_STRING(--enable-coverage, [enable coverage support in the unit-test build]))
+AC_ARG_ENABLE(asserts-in-tests,
+ AS_HELP_STRING(--disable-asserts-in-tests, [disable tor_assert() calls in the unit tests, for branch coverage]))
AC_ARG_ENABLE(system-torrc,
AS_HELP_STRING(--disable-system-torrc, [don't look for a system-wide torrc file]))
+if test x$enable_coverage != xyes -a x$enable_asserts_in_tests = xno ; then
+ AC_MSG_ERROR([Can't disable assertions outside of coverage build])
+fi
+
+
AM_CONDITIONAL(UNITTESTS_ENABLED, test x$enable_unittests != xno)
AM_CONDITIONAL(COVERAGE_ENABLED, test x$enable_coverage = xyes)
+AM_CONDITIONAL(DISABLE_ASSERTS_IN_UNIT_TESTS, test x$enable_asserts_in_tests = xno)
if test "$enable_static_tor" = "yes"; then
enable_static_libevent="yes";