summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-02-15 20:28:07 -0500
committerNick Mathewson <nickm@torproject.org>2018-02-15 20:28:07 -0500
commita1dd8afc16ebeacceb5b4093ef01e2ad8f21ad6c (patch)
tree3d4cb5e1b1b26d1115beb1616b6dc04c83bf7fc1 /configure.ac
parent066a15af635b1e75476834812f6a326eecf9aa98 (diff)
parenta03488954c15b2fe2643d19c5530d9c927665b6f (diff)
downloadtor-a1dd8afc16ebeacceb5b4093ef01e2ad8f21ad6c.tar.gz
tor-a1dd8afc16ebeacceb5b4093ef01e2ad8f21ad6c.zip
Merge branch '25162_zstd_static'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1540c40f9c..4c751d1eb6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,6 +61,8 @@ AC_ARG_ENABLE(cargo-online-mode,
AS_HELP_STRING(--enable-cargo-online-mode, [Allow cargo to make network requests to fetch crates. For builds with rust only.]))
AC_ARG_ENABLE(restart-debugging,
AS_HELP_STRING(--enable-restart-debugging, [Build Tor with support for debugging in-process restart. Developers only.]))
+AC_ARG_ENABLE(zstd-advanced-apis,
+ AS_HELP_STRING(--disable-zstd-advanced-apis, [Build without support for zstd's "static-only" APIs.]))
if test "x$enable_coverage" != "xyes" -a "x$enable_asserts_in_tests" = "xno" ; then
AC_MSG_ERROR([Can't disable assertions outside of coverage build])
@@ -114,6 +116,10 @@ if test "$enable_restart_debugging" = "yes"; then
[Defined if we're building with support for in-process restart debugging.])
fi
+if test "$enable_zstd_advanced_apis" != "no"; then
+ AC_DEFINE(ENABLE_ZSTD_ADVANCED_APIS, 1,
+ [Defined if we're going to try to use zstd's "static-only" APIs.])
+fi
# systemd support
if test "x$enable_systemd" = "xno"; then