summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-08-15 12:20:57 -0400
committerNick Mathewson <nickm@torproject.org>2018-08-15 12:20:57 -0400
commit0fc171a47be0cb3b1021816ab80ef823063ce2d1 (patch)
tree0066d25709d207eeace78a9b879c21c5208c419c /configure.ac
parent1868982de6c538b75ab599b332fa896492608620 (diff)
parenta26a2735b9cf9c6940d784f755f983088c333833 (diff)
downloadtor-0fc171a47be0cb3b1021816ab80ef823063ce2d1.tar.gz
tor-0fc171a47be0cb3b1021816ab80ef823063ce2d1.zip
Merge branch 'maint-0.3.2' into maint-0.3.3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8e6683bb71..5b717d38f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -515,8 +515,10 @@ if test "$LIBS" != "$saved_LIBS"; then
have_rt=yes
fi
-AC_SEARCH_LIBS(pthread_create, [pthread])
-AC_SEARCH_LIBS(pthread_detach, [pthread])
+if test "$bwin32" = "false"; then
+ AC_SEARCH_LIBS(pthread_create, [pthread])
+ AC_SEARCH_LIBS(pthread_detach, [pthread])
+fi
AM_CONDITIONAL(THREADS_WIN32, test "$bwin32" = "true")
AM_CONDITIONAL(THREADS_PTHREADS, test "$bwin32" = "false")