summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-08-03 07:33:45 -0400
committerNick Mathewson <nickm@torproject.org>2018-08-03 07:33:45 -0400
commitae157b79e76695b8afe580da033789ba92b7ffdf (patch)
treea288a2fceb3e84fee157847b600c24e5767b3435 /configure.ac
parent622a057e7e5d9f757d040283c7089d1fab847ae3 (diff)
parentbe8e56c231755069fae03eb13a4ddd9fba4f6563 (diff)
downloadtor-ae157b79e76695b8afe580da033789ba92b7ffdf.tar.gz
tor-ae157b79e76695b8afe580da033789ba92b7ffdf.zip
Merge branch 'maint-0.3.4'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 32eed75bf9..ebd4153742 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1807,6 +1807,10 @@ fi
if test "$using_custom_malloc" = "no"; then
AC_CHECK_FUNCS(mallinfo)
fi
+if test "$using_custom_malloc" = "yes"; then
+ # Tell the C compiler not to use the system allocator functions.
+ TOR_CHECK_CFLAGS([-fno-builtin-malloc -fno-builtin-realloc -fno-builtin-calloc -fno-builtin-free])
+fi
# By default, we're going to assume we don't have mlockall()
# bionic and other platforms have various broken mlockall subsystems.