summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-06-21 09:28:50 -0400
committerNick Mathewson <nickm@torproject.org>2018-06-21 09:31:01 -0400
commit47ee7978fe73816bf15cb392d0e89301f65724f8 (patch)
treedf51fed9d9669501a9657824db1063043b70a83a /configure.ac
parentef671147f21814ed505505ec96bfcf297bc6bb7a (diff)
downloadtor-47ee7978fe73816bf15cb392d0e89301f65724f8.tar.gz
tor-47ee7978fe73816bf15cb392d0e89301f65724f8.zip
Prefer recent Python 3 in autoconf.
Closes ticket 26372.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 15ecbe60e1..279660d9b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -213,7 +213,11 @@ AM_PROG_CC_C_O
AC_PROG_CC_C99
AC_ARG_VAR([PYTHON], [path to Python binary])
-AC_CHECK_PROGS(PYTHON, [python python2 python2.7 python3 python3.3])
+AC_CHECK_PROGS(PYTHON, [ \
+ python3 \
+ python3.8 python3.7 python3.6 python3.5 python3.4 \
+ python \
+ python2 python2.7])
if test "x$PYTHON" = "x"; then
AC_MSG_WARN([Python unavailable; some tests will not be run.])
fi