summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChelsea Holland Komlo <me@chelseakomlo.com>2017-09-27 19:48:07 +0000
committerNick Mathewson <nickm@torproject.org>2017-10-27 10:02:08 -0400
commitd1820c1516a31a149fc51a9e5126bf899e4c4e08 (patch)
treeea2ed5c2259f87ca078378eff4f78c9bf0aa50da /configure.ac
parent5418aa84eec9f08af7ab7b68cbc9145750ad0a1b (diff)
downloadtor-d1820c1516a31a149fc51a9e5126bf899e4c4e08.tar.gz
tor-d1820c1516a31a149fc51a9e5126bf899e4c4e08.zip
rust implementation of protover
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d2682944fb..b2b353f6ba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -440,11 +440,17 @@ if test "x$enable_rust" = "xyes"; then
dnl the MSVC naming convention.
if test "$bwin32" = "true"; then
TOR_RUST_UTIL_STATIC_NAME=tor_util.lib
+ TOR_RUST_PROTOVER_STATIC_NAME=libprotover.lib
+ TOR_RUST_C_STRING_STATIC_NAME=libc_string.lib
else
TOR_RUST_UTIL_STATIC_NAME=libtor_util.a
+ TOR_RUST_PROTOVER_STATIC_NAME=libprotover.a
+ TOR_RUST_C_STRING_STATIC_NAME=libc_string.a
fi
AC_SUBST(TOR_RUST_UTIL_STATIC_NAME)
+ AC_SUBST(TOR_RUST_PROTOVER_STATIC_NAME)
+ AC_SUBST(TOR_RUST_C_STRING_STATIC_NAME)
AC_SUBST(CARGO_ONLINE)
AC_SUBST(RUST_DL)