summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-01-19 09:52:14 -0500
committerNick Mathewson <nickm@torproject.org>2018-01-19 09:52:14 -0500
commit2c9e0a286cad3c0bbc1797f75a8c516df476db62 (patch)
treee1573bd20873474a7464ee79ef3be2162ab00eee /configure.ac
parente7907f15f9b7685fbdd24939a7266235a066f8a0 (diff)
parent97d9ba2380e0c894a1b611bdb4f35d0fe98a837a (diff)
downloadtor-2c9e0a286cad3c0bbc1797f75a8c516df476db62.tar.gz
tor-2c9e0a286cad3c0bbc1797f75a8c516df476db62.zip
Merge branch 'restart_debug_squashed'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9bb09b2dfa..569cfcd4c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,6 +59,8 @@ AC_ARG_ENABLE(rust,
AS_HELP_STRING(--enable-rust, [enable rust integration]))
AC_ARG_ENABLE(cargo-online-mode,
AS_HELP_STRING(--enable-cargo-online-mode, [Allow cargo to make network requests to fetch crates. For builds with rust only.]))
+AC_ARG_ENABLE(restart-debugging,
+ AS_HELP_STRING(--enable-restart-debugging, [Build Tor with support for debugging in-process restart. Developers only.]))
if test "x$enable_coverage" != "xyes" -a "x$enable_asserts_in_tests" = "xno" ; then
AC_MSG_ERROR([Can't disable assertions outside of coverage build])
@@ -107,6 +109,10 @@ AC_ARG_ENABLE(systemd,
* ) AC_MSG_ERROR(bad value for --enable-systemd) ;;
esac], [systemd=auto])
+if test "$enable_restart_debugging" = "yes"; then
+ AC_DEFINE(ENABLE_RESTART_DEBUGGING, 1,
+ [Defined if we're building with support for in-process restart debugging.])
+fi
# systemd support