summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2013-01-16 13:56:10 -0500
committerNick Mathewson <nickm@torproject.org>2013-01-16 13:56:10 -0500
commit65e6e68981d9910c5f78f2cfed6c59cbee1494c7 (patch)
treec4ac9df87c63144380a605327da0b37ea08fb1e1 /configure.ac
parent7fc91dc274f38dc50f2a6eef2db060c788ef3040 (diff)
parent50f527a2c9202105a84e5f6c7d2844c494a46b7d (diff)
downloadtor-65e6e68981d9910c5f78f2cfed6c59cbee1494c7.tar.gz
tor-65e6e68981d9910c5f78f2cfed6c59cbee1494c7.zip
Merge branch 'bug7972'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index acd20838da..f047ab9027 100644
--- a/configure.ac
+++ b/configure.ac
@@ -689,13 +689,20 @@ if test x$enable_curve25519 != xno; then
[tor_cv_can_use_curve25519_donna_c64=cross],
[tor_cv_can_use_curve25519_donna_c64=no])])])
+ AC_CHECK_HEADERS([crypto_scalarmult_curve25519.h \
+ nacl/crypto_scalarmult_curve25519.h])
+
AC_CACHE_CHECK([whether we can use curve25519 from nacl],
tor_cv_can_use_curve25519_nacl,
[tor_saved_LIBS="$LIBS"
LIBS="$LIBS -lnacl"
AC_LINK_IFELSE(
[AC_LANG_PROGRAM([dnl
+ #ifdef HAVE_CRYPTO_SCALARMULT_CURVE25519_H
#include <crypto_scalarmult_curve25519.h>
+ #elif defined(HAVE_NACL_CRYPTO_SCALARMULT_CURVE25519_H)
+ #include <nacl/crypto_scalarmult_curve25519.h>
+ #endif
#ifdef crypto_scalarmult_curve25519_ref_BYTES
#error Hey, this is the reference implementation!
#endif