summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2013-03-15 11:01:06 -0400
committerNick Mathewson <nickm@torproject.org>2013-03-15 11:01:06 -0400
commit2810753928692ca86820f4df3b4a76caf2701d33 (patch)
treee8b3930b067a9f9962256e8ba6d91c390e1fdf1c /configure.ac
parent9be3389dc70fc36c29f8ba97c7d642eecb8a5789 (diff)
parent10fb3398087133add9aff93740aff8f818edf242 (diff)
downloadtor-2810753928692ca86820f4df3b4a76caf2701d33.tar.gz
tor-2810753928692ca86820f4df3b4a76caf2701d33.zip
Merge remote-tracking branch 'origin/maint-0.2.4'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0ac8255f2f..08da2739fb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -706,7 +706,7 @@ if test x$enable_curve25519 != xno; then
AC_CHECK_HEADERS([crypto_scalarmult_curve25519.h \
nacl/crypto_scalarmult_curve25519.h])
- AC_CACHE_CHECK([whether we can use curve25519 from nacl],
+ AC_CACHE_CHECK([for nacl compiled with a fast curve25519 implementation],
tor_cv_can_use_curve25519_nacl,
[tor_saved_LIBS="$LIBS"
LIBS="$LIBS -lnacl"
@@ -718,7 +718,7 @@ if test x$enable_curve25519 != xno; then
#include <nacl/crypto_scalarmult_curve25519.h>
#endif
#ifdef crypto_scalarmult_curve25519_ref_BYTES
- #error Hey, this is the reference implementation!
+ #error Hey, this is the reference implementation! That's not fast.
#endif
], [
unsigned char *a, *b, *c; crypto_scalarmult_curve25519(a,b,c);