summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorcypherpunks <cypherpunks@torproject.org>2016-12-15 12:02:42 +0000
committerNick Mathewson <nickm@torproject.org>2016-12-16 10:52:15 -0500
commit032da29d28599cfb76afd58e2bff4662912ae109 (patch)
tree2a75a8ce6fdd825823bf8cd3b62e6019641d89d0 /configure.ac
parente8760b6e51e9320ae039b3521b5b984e2bd8ac0c (diff)
downloadtor-032da29d28599cfb76afd58e2bff4662912ae109.tar.gz
tor-032da29d28599cfb76afd58e2bff4662912ae109.zip
Run check-spaces only when Perl is available
Also permit users to override the Perl variable with relative paths.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index afe40a407c..552465c77c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -195,7 +195,9 @@ AC_PROG_CPP
AC_PROG_MAKE_SET
AC_PROG_RANLIB
-AC_PATH_PROG([PERL], [perl])
+AC_ARG_VAR([PERL], [path to Perl binary])
+AC_CHECK_PROGS([PERL], [perl])
+AM_CONDITIONAL(USE_PERL, [test "x$ac_cv_prog_PERL" != "x"])
dnl autoconf 2.59 appears not to support AC_PROG_SED
AC_CHECK_PROG([SED],[sed],[sed],[/bin/false])