summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorcypherpunks <cypherpunks@torproject.org>2016-06-17 13:43:25 +0000
committerNick Mathewson <nickm@torproject.org>2016-06-17 10:17:44 -0400
commit94762e37b950f3ce1696c78dd4f7a89b6d05f1ac (patch)
treee9b3517710fc601d2e7cac22d0620498cc145a0c /configure.ac
parent9a63f059b9eefa910a8c74b4936623dd37e946dd (diff)
downloadtor-94762e37b950f3ce1696c78dd4f7a89b6d05f1ac.tar.gz
tor-94762e37b950f3ce1696c78dd4f7a89b6d05f1ac.zip
Use the Autoconf macro AC_USE_SYSTEM_EXTENSIONS
The Autoconf macro AC_USE_SYSTEM_EXTENSIONS defines preprocessor macros which turn on extensions to C and POSIX. The macro also makes it easier for developers to use the extensions without needing (or forgetting) to define them manually. The macro can be safely used because it was introduced in Autoconf 2.60 and Tor requires Autoconf 2.63 and above.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 386fcdd132..6d721a2fc5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,6 +16,7 @@ AM_INIT_AUTOMAKE([foreign 1.11 subdir-objects])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
AC_CONFIG_HEADERS([orconfig.h])
+AC_USE_SYSTEM_EXTENSIONS
AC_CANONICAL_HOST
PKG_PROG_PKG_CONFIG
@@ -1552,9 +1553,6 @@ int main(int c, char **v) { puts(__FUNCTION__); }])],
AC_CACHE_CHECK([whether we have extern char **environ already declared],
tor_cv_have_environ_declared,
AC_COMPILE_IFELSE([AC_LANG_SOURCE([
-/* We define _GNU_SOURCE here because it is also defined in compat.c.
- * Without it environ doesn't get declared. */
-#define _GNU_SOURCE
#ifdef HAVE_UNISTD_H
#include <unistd.h>
#endif