summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-01-24 19:10:46 -0500
committerNick Mathewson <nickm@torproject.org>2015-01-26 10:03:45 -0500
commit5bf0809744637a868265c89cf86481135019f2ac (patch)
tree884da4f7826ef653f5f583ac57fb2f6d23dc04d3 /configure.ac
parent8f9fb3e8fae31e3c14811911f23537cfecc6b780 (diff)
downloadtor-5bf0809744637a868265c89cf86481135019f2ac.tar.gz
tor-5bf0809744637a868265c89cf86481135019f2ac.zip
configure.ac: fix disabling systemd notification support
If --disable-systemd is given, $enable_systemd is set to "no", not "false". As a result, if libsystemd is found, we still turn on systemd support even if we explicitly disable it with --disable-system.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9aac1e8c55..af16edfe49 100644
--- a/configure.ac
+++ b/configure.ac
@@ -126,7 +126,7 @@ AC_ARG_ENABLE(systemd,
# systemd support
-if test x$enable_systemd = xfalse ; then
+if test x$enable_systemd = xno ; then
have_systemd=no;
else
PKG_CHECK_MODULES(SYSTEMD,