summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2016-08-11 20:37:18 -0400
committerNick Mathewson <nickm@torproject.org>2016-08-11 20:37:18 -0400
commite788c577f11ef4c0309e9d5298bf57639c0ebb06 (patch)
tree9f53f02ba7fcc8317299c93a471aeac71d8c3979 /configure.ac
parent60997a00e8e7585e076c750ab37095c0bfc3c773 (diff)
downloadtor-e788c577f11ef4c0309e9d5298bf57639c0ebb06.tar.gz
tor-e788c577f11ef4c0309e9d5298bf57639c0ebb06.zip
Only use evutil_secure_rng_add_bytes() when present.
OpenBSD removes this function, and now that Tor requires Libevent 2, we should also support the OpenBSD Libevent 2. Fixes bug 19904; bugfix on 0.2.5.4-alpha.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index be7c4e8f65..a1a55e1b40 100644
--- a/configure.ac
+++ b/configure.ac
@@ -500,7 +500,9 @@ save_CPPFLAGS="$CPPFLAGS"
LIBS="-levent $STATIC_LIBEVENT_FLAGS $TOR_LIB_WS32 $LIBS"
LDFLAGS="$TOR_LDFLAGS_libevent $LDFLAGS"
CPPFLAGS="$TOR_CPPFLAGS_libevent $CPPFLAGS"
-AC_CHECK_FUNCS([evutil_secure_rng_set_urandom_device_file])
+AC_CHECK_FUNCS([evutil_secure_rng_set_urandom_device_file \
+ evutil_secure_rng_add_bytes \
+])
LIBS="$STATIC_LIBEVENT_FLAGS $TOR_LIB_WS32 $save_LIBS"