summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2016-05-11 12:15:37 -0400
committerNick Mathewson <nickm@torproject.org>2016-05-11 12:15:37 -0400
commitc662bef45595e40106becfbdbb39811300d15a7f (patch)
tree245c831335a05e0eae972551c6defb8d7233a49f /configure.ac
parent368146370b699781334a8f380d764b3246881f52 (diff)
downloadtor-c662bef45595e40106becfbdbb39811300d15a7f.tar.gz
tor-c662bef45595e40106becfbdbb39811300d15a7f.zip
Undefine _FORTIFY_SOURCE before defining it.
This makes our compilation options checks in autoconf work better on systems that already define _FORTIFY_SOURCE. Fixes at least one case of bug 18841; bugfix on 0.2.3.17-beta. Patch from "trudokal".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 29ba2fd6ce..2116b41fd5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -623,7 +623,7 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [
#endif])], have_clang=yes, have_clang=no)
if test x$enable_gcc_hardening != xno; then
- CFLAGS="$CFLAGS -D_FORTIFY_SOURCE=2"
+ CFLAGS="$CFLAGS -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2"
if test x$have_clang = xyes; then
TOR_CHECK_CFLAGS(-Qunused-arguments)
fi