summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2016-10-06 12:58:49 -0400
committerNick Mathewson <nickm@torproject.org>2016-10-06 12:58:49 -0400
commit850ec1e2822482435bb0efa8853a74d6f0feaa20 (patch)
treef080f1007ad3aa124848c3abe4d2049cc042de9d /configure.ac
parent80e2896d52981579042cc906766bc0444da7a1d3 (diff)
downloadtor-850ec1e2822482435bb0efa8853a74d6f0feaa20.tar.gz
tor-850ec1e2822482435bb0efa8853a74d6f0feaa20.zip
Stop implying that we support openssl 1.0.0; we don't.
Closes ticket 20303. The LIBRESSL_VERSION_NUMBER check is needed because if our openssl is really libressl, it will have an openssl version number we can't really believe.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 23371d3b4b..af42896dc8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -614,12 +614,12 @@ CPPFLAGS="$TOR_CPPFLAGS_openssl $CPPFLAGS"
AC_TRY_COMPILE([
#include <openssl/opensslv.h>
-#if OPENSSL_VERSION_NUMBER < 0x1000000fL
+#if !defined(LIBRESSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER < 0x1000100fL
#error "too old"
#endif
], [],
[ : ],
- [ AC_ERROR([OpenSSL is too old. We require 1.0.0 or later. You can specify a path to a newer one with --with-openssl-dir.]) ])
+ [ AC_ERROR([OpenSSL is too old. We require 1.0.1 or later. You can specify a path to a newer one with --with-openssl-dir.]) ])
AC_TRY_COMPILE([
#include <openssl/opensslv.h>