summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2016-05-19 16:38:24 -0400
committerNick Mathewson <nickm@torproject.org>2016-05-19 16:38:24 -0400
commit60ac07940f06b4574c3ae044c8fea20777198fa4 (patch)
tree410ec07057a3dcb713a7097f24972b6d3bf06b6b /configure.ac
parentdcc4fd440392eec3dd8796c9c759faed51a61db0 (diff)
downloadtor-60ac07940f06b4574c3ae044c8fea20777198fa4.tar.gz
tor-60ac07940f06b4574c3ae044c8fea20777198fa4.zip
Fix "conditional "ADD_MULODI4" was never defined".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f8cad48b17..1ee87a5307 100644
--- a/configure.ac
+++ b/configure.ac
@@ -801,6 +801,7 @@ fi
CFLAGS_BUGTRAP="$CFLAGS_FTRAPV $CFLAGS_ASAN $CFLAGS_UBSAN"
CFLAGS_CONSTTIME="$CFLAGS_FWRAPV"
+mulodi_fixes_ftrapv=no
if test "$have_clang" = "yes"; then
saved_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS $CFLAGS_FTRAPV"
@@ -817,7 +818,6 @@ if test "$have_clang" = "yes"; then
} ]])],
[ftrapv_can_link=yes; AC_MSG_RESULT([yes])],
[ftrapv_can_link=no; AC_MSG_RESULT([no])])
- mulodi_fixes_ftrapv=no
if test "$ftrapv_can_link" = "no"; then
AC_MSG_CHECKING([whether defining __mulodi4 fixes that])
AC_LINK_IFELSE([
@@ -837,10 +837,11 @@ if test "$have_clang" = "yes"; then
[mulodi_fixes_ftrapv=yes; AC_MSG_RESULT([yes])],
[mulodi_fixes_ftrapv=no; AC_MSG_RESULT([no])])
fi
- AM_CONDITIONAL(ADD_MULODI4, test "$mulodi_fixes_ftrapv" = "yes")
CFLAGS="$saved_CFLAGS"
fi
+AM_CONDITIONAL(ADD_MULODI4, test "$mulodi_fixes_ftrapv" = "yes")
+
dnl These cflags add bunches of branches, and we haven't been able to
dnl persuade ourselves that they're suitable for code that needs to be
dnl constant time.