summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2016-12-01 10:05:44 -0500
committerNick Mathewson <nickm@torproject.org>2016-12-01 10:05:44 -0500
commit52cb1edda69b7f73b2aa7a8edfbc850a0b3769ff (patch)
tree6485cececc71e53b37f9d4004b56d004aef27ef6 /configure.ac
parentf8a7972b29b83c08c64a8bc04a19c2ef33f50ccb (diff)
parent16fcbd21c963a9a65bf55024680c8323c8b7175d (diff)
downloadtor-52cb1edda69b7f73b2aa7a8edfbc850a0b3769ff.tar.gz
tor-52cb1edda69b7f73b2aa7a8edfbc850a0b3769ff.zip
Merge branch 'maint-0.2.8' into maint-0.2.9
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 28 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1acbe04ef5..1d56b9bcd6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -379,14 +379,12 @@ AC_CHECK_FUNCS(
accept4 \
backtrace \
backtrace_symbols_fd \
- clock_gettime \
eventfd \
explicit_bzero \
timingsafe_memcmp \
flock \
ftime \
getaddrinfo \
- getentropy \
getifaddrs \
getpass \
getrlimit \
@@ -424,6 +422,34 @@ AC_CHECK_FUNCS(
_vscprintf
)
+# Apple messed up when they added two functions functions in Sierra: they
+# forgot to decorate them with appropriate AVAILABLE_MAC_OS_VERSION
+# checks. So we should only probe for those functions if we are sure that we
+# are not targetting OSX 10.11 or earlier.
+AC_MSG_CHECKING([for a pre-Sierra OSX build target])
+AC_TRY_COMPILE([
+#ifdef __APPLE__
+# include <AvailabilityMacros.h>
+# ifndef MAC_OS_VERSION_10_12
+# define MAC_OS_VERSION_10_12 101200
+# endif
+# if defined(MAC_OS_X_VERSION_MIN_REQUIRED)
+# if MAC_OS_X_VERSION_MIN_REQUIRED < MAC_OS_VERSION_10_12
+# error "Running on Mac OSX 10.11 or earlier"
+# endif
+# endif
+#endif
+], [],
+ [on_macos_pre_10_12=no ; AC_MSG_RESULT([no])],
+ [on_macos_pre_10_12=yes; AC_MSG_RESULT([yes])])
+
+if test "$on_macos_pre_10_12" = "no"; then
+ AC_CHECK_FUNCS(
+ clock_gettime \
+ getentropy \
+ )
+fi
+
if test "$bwin32" != "true"; then
AC_CHECK_HEADERS(pthread.h)
AC_CHECK_FUNCS(pthread_create)