summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorcypherpunks <cypherpunks@torproject.org>2016-02-26 12:53:28 +0000
committerNick Mathewson <nickm@torproject.org>2016-03-11 10:08:53 -0500
commit25fa21802f578db0e2852084a95a23b60ef1d1e9 (patch)
tree1bef9565ae8d1b59649d6ac503998ac518fdc27f /configure.ac
parentef31c8862f4ed86cfa4987b2ec58468269457f87 (diff)
downloadtor-25fa21802f578db0e2852084a95a23b60ef1d1e9.tar.gz
tor-25fa21802f578db0e2852084a95a23b60ef1d1e9.zip
Move Automake options to configure.ac
This will centralize the version configuration in one file to simplify future changes. Also fixes some typos in the Automake options comments.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a4581e54c3..df4b9cdc08 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,7 +7,12 @@ AC_PREREQ([2.63])
AC_INIT([tor],[0.2.8.1-alpha-dev])
AC_CONFIG_SRCDIR([src/or/main.c])
AC_CONFIG_MACRO_DIR([m4])
-AM_INIT_AUTOMAKE
+
+# "foreign" means we don't follow GNU package layout standards
+# "1.11" means we require automake version 1.11 or newer
+# "subdir-objects" means put .o files in the same directory as the .c files
+AM_INIT_AUTOMAKE([foreign 1.11 subdir-objects])
+
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
AC_CONFIG_HEADERS([orconfig.h])