summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2016-05-30 12:05:08 -0400
committerNick Mathewson <nickm@torproject.org>2016-06-11 10:11:52 -0400
commit12517c73039afa5632b475a447e277a0ec73fbd5 (patch)
tree1827c5316cf8a1276a2bab0fc28ee7ba467c40d9 /configure.ac
parentb14c1f40826d9e2383707036b6e524f6756aa5d5 (diff)
downloadtor-12517c73039afa5632b475a447e277a0ec73fbd5.tar.gz
tor-12517c73039afa5632b475a447e277a0ec73fbd5.zip
Add -Wduplicated-cond on GCC 6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4878d2ba7e..d9149e26ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1777,6 +1777,7 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [
if test "x$have_gcc6" = "xyes"; then
CFLAGS="$CFLAGS -Wignored-attributes -Wshift-negative-value -Wshift-overflow=2"
CFLAGS="$CFLAGS -Wnull-dereference"
+ CFLAGS="$CFLAGS -Wduplicated-cond"
fi
if test "x$have_shorten64_flag" = "xyes"; then