summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2016-03-25 16:26:13 -0400
committerNick Mathewson <nickm@torproject.org>2016-03-25 16:26:13 -0400
commitdb1352703c281fb5de355f76a00c092b52bcafda (patch)
treefa0c63b1d18e826f59902a195827928c56587657 /configure.ac
parente1e62f9d5735da64dc1435d3a40db77f6229766a (diff)
downloadtor-db1352703c281fb5de355f76a00c092b52bcafda.tar.gz
tor-db1352703c281fb5de355f76a00c092b52bcafda.zip
Remove spurious exit() calls from configure.ac
We added these a while ago, but they do no actual good, and cause implicit declaration warnings in some situations. Rather than just adding stdint.h, it's easier to remove the exit() calls as redundant. Fixes bug 18626; bugfix from "cypherpunks"
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index bf6d7f66ea..0c0091020e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -473,19 +473,18 @@ TOR_SEARCH_LIBRARY(libevent, $trylibeventdir, [-levent $STATIC_LIBEVENT_FLAGS $T
#ifdef _WIN32
#include <winsock2.h>
#endif
-#include <stdlib.h>
#include <sys/time.h>
#include <sys/types.h>
#include <event.h>], [
#ifdef _WIN32
#include <winsock2.h>
#endif
-void exit(int); void *event_init(void);],
+void *event_init(void);],
[
#ifdef _WIN32
{WSADATA d; WSAStartup(0x101,&d); }
#endif
-event_init(); exit(0);
+event_init();
], [--with-libevent-dir], [/opt/libevent])
dnl Now check for particular libevent functions.
@@ -611,7 +610,7 @@ AC_ARG_WITH(ssl-dir,
TOR_SEARCH_LIBRARY(openssl, $tryssldir, [-lssl -lcrypto $TOR_LIB_GDI],
[#include <openssl/rand.h>],
[void RAND_add(const void *buf, int num, double entropy);],
- [RAND_add((void*)0,0,0); exit(0);], [],
+ [RAND_add((void*)0,0,0);], [],
[/usr/local/openssl /usr/lib/openssl /usr/local/ssl /usr/lib/ssl /usr/local /usr/athena /opt/openssl])
dnl XXXX check for OPENSSL_VERSION_NUMBER == SSLeay()
@@ -688,7 +687,7 @@ tor_zlib_devpkg_debian="zlib1g-dev"
TOR_SEARCH_LIBRARY(zlib, $tryzlibdir, [-lz],
[#include <zlib.h>],
[const char * zlibVersion(void);],
- [zlibVersion(); exit(0);], [--with-zlib-dir],
+ [zlibVersion();], [--with-zlib-dir],
[/opt/zlib])
if test "$enable_static_zlib" = "yes"; then