summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2016-05-30 14:13:33 -0400
committerNick Mathewson <nickm@torproject.org>2016-06-11 10:11:52 -0400
commit4caed2424a449712c8ac267d521563d31536aa6a (patch)
tree262ec1efd589f9639f28c6c09d2b4ab59e1d0d03 /configure.ac
parent8f2d2933f912c9952453b17b19636c26579e2323 (diff)
downloadtor-4caed2424a449712c8ac267d521563d31536aa6a.tar.gz
tor-4caed2424a449712c8ac267d521563d31536aa6a.zip
Enable -Woverlength-strings for GCC>=4.6 on MOST of the code.
IMO it's fine for us to make exceptions to this rule in the unit tests, but not in the code at large.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 38c922bdd1..f21d9de532 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1757,6 +1757,7 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [
# and these should be just fine in gcc 4.6
CFLAGS="$CFLAGS -Wmissing-format-attribute -Wsuggest-attribute=noreturn -Wsync-nand -Wtrampolines -Wunused-but-set-parameter -Wunused-but-set-variable -Wvariadic-macros"
CFLAGS="$CFLAGS -Wdouble-promotion"
+ CFLAGS="$CFLAGS -Woverlength-strings"
fi
if test "x$have_gcc47" = "xyes"; then