summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2016-05-30 12:28:55 -0400
committerNick Mathewson <nickm@torproject.org>2016-06-11 10:11:52 -0400
commit2ff20c93a5ec753a0c46ca5ecd991b8e2020f7d0 (patch)
treec49afdb5e8db4b8fdc07355ec0c997401accea9f /configure.ac
parent12517c73039afa5632b475a447e277a0ec73fbd5 (diff)
downloadtor-2ff20c93a5ec753a0c46ca5ecd991b8e2020f7d0.tar.gz
tor-2ff20c93a5ec753a0c46ca5ecd991b8e2020f7d0.zip
Add -Wunused-const-variable=2 on GCC >=6.1
This caused a trivial warning in curve25519-donna-64bit.h, which had two unused constants. I commented them out.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d9149e26ec..f66d798713 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1778,6 +1778,7 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [
CFLAGS="$CFLAGS -Wignored-attributes -Wshift-negative-value -Wshift-overflow=2"
CFLAGS="$CFLAGS -Wnull-dereference"
CFLAGS="$CFLAGS -Wduplicated-cond"
+ CFLAGS="$CFLAGS -Wunused-const-variable=2"
fi
if test "x$have_shorten64_flag" = "xyes"; then