summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2016-01-29 09:18:59 -0500
committerNick Mathewson <nickm@torproject.org>2016-01-29 09:18:59 -0500
commit5f7df92571ec5a2d1eddb257e22f5489acc4fc83 (patch)
tree9ef43ebc29ec04a5fe42f2411b3aa61ac2f643c8 /configure.ac
parenta5bed4dab2f8521f744d5137e4f439b073c7e5e9 (diff)
downloadtor-5f7df92571ec5a2d1eddb257e22f5489acc4fc83.tar.gz
tor-5f7df92571ec5a2d1eddb257e22f5489acc4fc83.zip
Remove support for unsigned time_t
We've never actually tested this support, and we should probably assume it's broken. To the best of my knowledge, only OpenVMS has this, and even on OpenVMS it's a compile-time option to disable it. And I don't think we build on openvms anyway. (Everybody else seems to be working around the 2038 problem by using a 64-bit time_t, which won't expire for roughly 292 billion years.) Closes ticket 18184.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6d2312d159..de7221dc90 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1176,7 +1176,7 @@ AC_CHECK_TYPES([rlim_t], , ,
])
AX_CHECK_SIGN([time_t],
- [ AC_DEFINE(TIME_T_IS_SIGNED, 1, [Define if time_t is signed]) ],
+ [ : ],
[ : ], [
#ifdef HAVE_SYS_TYPES_H
#include <sys/types.h>
@@ -1190,7 +1190,7 @@ AX_CHECK_SIGN([time_t],
])
if test "$ax_cv_decl_time_t_signed" = no; then
- AC_MSG_WARN([You have an unsigned time_t; some things will probably break. Please tell the Tor developers about your interesting platform.])
+ AC_MSG_ERROR([You have an unsigned time_t; Tor does not support that. Please tell the Tor developers about your interesting platform.])
fi
AX_CHECK_SIGN([size_t],