summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2016-05-27 11:26:14 -0400
committerNick Mathewson <nickm@torproject.org>2016-05-27 11:26:14 -0400
commitce1dbbc4fdd7ab6fab4f31a0e54d9ca97afe74a9 (patch)
tree354dedd9d603f203aa65b1755138cf939e8216b6 /configure.ac
parent0df2c5677a79aafc32591b15ca07d25c638b68cc (diff)
downloadtor-ce1dbbc4fdd7ab6fab4f31a0e54d9ca97afe74a9.tar.gz
tor-ce1dbbc4fdd7ab6fab4f31a0e54d9ca97afe74a9.zip
Enable the -Waggregate-return warning
Suppress it in the one spot in the code where we actually do want to allow an aggregate return in order to call the mallinfo() API.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 29715c1a3d..d922eb636d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1698,8 +1698,7 @@ if test "x$enable_gcc_warnings_advisory" != "xno"; then
CFLAGS="$CFLAGS -Wredundant-decls -Wchar-subscripts -Wcomment -Wformat=2"
CFLAGS="$CFLAGS -Wwrite-strings -Wmissing-declarations -Wredundant-decls"
CFLAGS="$CFLAGS -Wnested-externs -Wbad-function-cast -Wswitch-enum"
-
- # Disabled, so we can use mallinfo(): -Waggregate-return
+ CFLAGS="$CFLAGS -Waggregate-return"
if test "x$have_gcc4" = "xyes"; then
# These warnings break gcc 3.3.5 and work on gcc 4.0.2