summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2016-05-30 13:57:32 -0400
committerNick Mathewson <nickm@torproject.org>2016-06-11 10:11:52 -0400
commit8f2d2933f912c9952453b17b19636c26579e2323 (patch)
tree2165851a39ac9517d9328481e230490ddc47f421 /configure.ac
parent493499a3399f8a8532b4b2a80006c033e8f64c58 (diff)
downloadtor-8f2d2933f912c9952453b17b19636c26579e2323.tar.gz
tor-8f2d2933f912c9952453b17b19636c26579e2323.zip
Use -Wdouble-promotion in GCC >= 4.6
This warning triggers on silently promoting a float to a double. In our code, it's just a sign that somebody used a float by mistake, since we always prefer double.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dc3a329ad4..38c922bdd1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1756,6 +1756,7 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [
CFLAGS="$CFLAGS -Wlogical-op"
# and these should be just fine in gcc 4.6
CFLAGS="$CFLAGS -Wmissing-format-attribute -Wsuggest-attribute=noreturn -Wsync-nand -Wtrampolines -Wunused-but-set-parameter -Wunused-but-set-variable -Wvariadic-macros"
+ CFLAGS="$CFLAGS -Wdouble-promotion"
fi
if test "x$have_gcc47" = "xyes"; then