summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2015-07-09 14:58:16 -0400
committerNick Mathewson <nickm@torproject.org>2015-07-09 14:58:16 -0400
commit4438b2a0e3822e464c4b6628944d76757d2237cb (patch)
tree76b94167ca4e9775bf17a75dc110bde1dcc6be1f /configure.ac
parentf19a75e19bba48e1a124ef8c73968bab5cbeee13 (diff)
downloadtor-4438b2a0e3822e464c4b6628944d76757d2237cb.tar.gz
tor-4438b2a0e3822e464c4b6628944d76757d2237cb.zip
More windows header stuff. Will it work this time?
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 19 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 6fbd489c65..e1501463c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -335,11 +335,25 @@ bwin32=true; AC_MSG_RESULT([yes]),
bwin32=false; AC_MSG_RESULT([no]))
fi
-if test "$bwin32" = true; then
- AC_DEFINE(WIN32_LEAN_AND_MEAN, 1, [Defined to avoid including some windows headers])
- AC_DEFINE(WINVER, 0x0501, [Defined to access windows functions and definitions for >=WinXP])
- AC_DEFINE(_WIN32_WINNT, 0x0501, [Defined to access windows functions and definitions for >=WinXP])
-fi
+AH_BOTTOM([
+#ifdef _WIN32
+/* Defined to access windows functions and definitions for >=WinXP */
+# ifndef WINVER
+# define WINVER 0x0501
+# endif
+
+/* Defined to access _other_ windows functions and definitions for >=WinXP */
+# ifndef _WIN32_WINNT
+# define _WIN32_WINNT 0x0501
+# endif
+
+/* Defined to avoid including some windows headers as part of Windows.h */
+# ifndef WIN32_LEAN_AND_MEAN
+# define WIN32_LEAN_AND_MEAN 1
+# endif
+#endif
+])
+
AM_CONDITIONAL(BUILD_NT_SERVICES, test x$bwin32 = xtrue)