summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2016-02-04 12:51:52 -0500
committerNick Mathewson <nickm@torproject.org>2016-02-04 12:51:52 -0500
commitaf116081f9d30d0830dc3c099c9c87f37b07d1f0 (patch)
treec4385d5f2919c605a3d68f84630bd2c2f3ea4134 /configure.ac
parent5da517e6897c4b997bb165dfd11e95f8f9c2bbbe (diff)
downloadtor-af116081f9d30d0830dc3c099c9c87f37b07d1f0.tar.gz
tor-af116081f9d30d0830dc3c099c9c87f37b07d1f0.zip
Make the no-assertions-during-coverage check into a configure option
Closes ticket 18242. The rationale here is that I like having coverage on by default in my own working directory, but I always want assertions turned on unless I'm doing branch coverage specifically.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1a78f41a30..d92f1e66a2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,6 +41,8 @@ AC_ARG_ENABLE(unittests,
AS_HELP_STRING(--disable-unittests, [don't build unit tests for Tor. Risky!]))
AC_ARG_ENABLE(coverage,
AS_HELP_STRING(--enable-coverage, [enable coverage support in the unit-test build]))
+AC_ARG_ENABLE(asserts-in-tests,
+ AS_HELP_STRING(--disable-asserts-in-tests, [disable tor_assert() calls in the unit tests, for branch coverage]))
AC_ARG_ENABLE(system-torrc,
AS_HELP_STRING(--disable-system-torrc, [don't look for a system-wide torrc file]))