summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2014-08-13 12:01:58 -0400
committerNick Mathewson <nickm@torproject.org>2014-08-13 12:01:58 -0400
commit883dc335e9ea3e0d944ce5cb3c6f140a6cad6ff1 (patch)
treeca64e7d3fa75495b7497f0f394623f767ee782dd /configure.ac
parentfcac4b4467427e8f6ad948e8c8e6f34a0131e716 (diff)
downloadtor-883dc335e9ea3e0d944ce5cb3c6f140a6cad6ff1.tar.gz
tor-883dc335e9ea3e0d944ce5cb3c6f140a6cad6ff1.zip
Fix configure script build with autoconf < 2.63
We added some AS_VAR_IF-based checks to detect whether we have managed to compile (but not link) with stack-protector. On autoconf before 2.63, we don't have AS_VAR_IF, so we just have to let the user get a compile error rather than a helpful "find libssp" error. Fixes bug 12693; bugfix on 0.2.5.2-alpha (commit 21ac292820da578)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c37f154222..55777e7b1b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -626,11 +626,12 @@ if test x$enable_gcc_hardening != xno; then
TOR_CHECK_CFLAGS(-fstack-protector-all, also_link)
AS_VAR_PUSHDEF([can_compile], [tor_cv_cflags_-fstack-protector-all])
AS_VAR_PUSHDEF([can_link], [tor_can_link_-fstack-protector-all])
+m4_ifdef([AS_VAR_IF],[
AS_VAR_IF(can_compile, [yes],
AS_VAR_IF(can_link, [yes],
[],
AC_MSG_ERROR([We tried to build with stack protection; it looks like your compiler supports it but your libc does not provide it. Are you missing libssp? (You can --disable-gcc-hardening to ignore this error.)]))
- )
+ )])
AS_VAR_POPDEF([can_link])
AS_VAR_POPDEF([can_compile])
TOR_CHECK_CFLAGS(-Wstack-protector)