summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRoger Dingledine <arma@torproject.org>2013-04-11 01:29:24 -0400
committerRoger Dingledine <arma@torproject.org>2013-04-11 01:29:24 -0400
commit887eba98950f2974bd2031510e1ece2279a4f106 (patch)
tree0bda88092333a1aa21925033596f395df4e3d4b1 /configure.ac
parentfcd9248387249d68619734a73860ffaab12b021b (diff)
parent6acf0ac2851fb95953edea9c231d82f487f28c3d (diff)
downloadtor-887eba98950f2974bd2031510e1ece2279a4f106.tar.gz
tor-887eba98950f2974bd2031510e1ece2279a4f106.zip
Merge branch 'maint-0.2.4' into release-0.2.4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 0d0cdf8401..56291aab97 100644
--- a/configure.ac
+++ b/configure.ac
@@ -693,7 +693,7 @@ if test x$enable_curve25519 != xno; then
AC_CHECK_HEADERS([crypto_scalarmult_curve25519.h \
nacl/crypto_scalarmult_curve25519.h])
- AC_CACHE_CHECK([whether we can use curve25519 from nacl],
+ AC_CACHE_CHECK([for nacl compiled with a fast curve25519 implementation],
tor_cv_can_use_curve25519_nacl,
[tor_saved_LIBS="$LIBS"
LIBS="$LIBS -lnacl"
@@ -705,7 +705,7 @@ if test x$enable_curve25519 != xno; then
#include <nacl/crypto_scalarmult_curve25519.h>
#endif
#ifdef crypto_scalarmult_curve25519_ref_BYTES
- #error Hey, this is the reference implementation!
+ #error Hey, this is the reference implementation! That's not fast.
#endif
], [
unsigned char *a, *b, *c; crypto_scalarmult_curve25519(a,b,c);
@@ -972,6 +972,10 @@ AX_CHECK_SIGN([time_t],
#endif
])
+if test "$ax_cv_decl_time_t_signed" = no; then
+ AC_MSG_WARN([You have an unsigned time_t; some things will probably break. Please tell the Tor developers about your interesting platform.])
+fi
+
AX_CHECK_SIGN([size_t],
[ tor_cv_size_t_signed=yes ],
[ tor_cv_size_t_signed=no ], [
@@ -980,7 +984,7 @@ AX_CHECK_SIGN([size_t],
#endif
])
-if test "$tor_cv_size_t_signed" = yes; then
+if test "$ax_cv_decl_size_t_signed" = yes; then
AC_MSG_ERROR([You have a signed size_t; that's grossly nonconformant.])
fi