aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2016-11-22 19:24:13 -0500
committerNick Mathewson <nickm@torproject.org>2016-11-22 19:24:13 -0500
commit16fcbd21c963a9a65bf55024680c8323c8b7175d (patch)
treeb0aaaf5aaab84b185d1c26c3209a61bc06056041 /configure.ac
parent2639fd08e7212bb33c0964b57028c013ce2271aa (diff)
downloadtor-16fcbd21c963a9a65bf55024680c8323c8b7175d.tar.gz
tor-16fcbd21c963a9a65bf55024680c8323c8b7175d.zip
Try to work around breakage in the OSX 10.12 SDK.
Apple is supposed to decorate their function declarations with macros to indicate which OSX version introduced them, so that you can tell the compiler that you want to build against certain versions of OSX. But they forgot to do that for clock_gettime() and getentropy(), both of which they introduced in 10.12. This patch adds a kludge to the configure.ac script where, if we detect that we are targeting OSX 10.11 or earlier, we don't even probe to see if the two offending functions are present. Closes ticket 20235.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 28 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index fb91f34246..6647523e0b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -394,14 +394,12 @@ AC_CHECK_FUNCS(
accept4 \
backtrace \
backtrace_symbols_fd \
- clock_gettime \
eventfd \
explicit_bzero \
timingsafe_memcmp \
flock \
ftime \
getaddrinfo \
- getentropy \
getifaddrs \
getpass \
getrlimit \
@@ -438,6 +436,34 @@ AC_CHECK_FUNCS(
_vscprintf
)
+# Apple messed up when they added two functions functions in Sierra: they
+# forgot to decorate them with appropriate AVAILABLE_MAC_OS_VERSION
+# checks. So we should only probe for those functions if we are sure that we
+# are not targetting OSX 10.11 or earlier.
+AC_MSG_CHECKING([for a pre-Sierra OSX build target])
+AC_TRY_COMPILE([
+#ifdef __APPLE__
+# include <AvailabilityMacros.h>
+# ifndef MAC_OS_VERSION_10_12
+# define MAC_OS_VERSION_10_12 101200
+# endif
+# if defined(MAC_OS_X_VERSION_MIN_REQUIRED)
+# if MAC_OS_X_VERSION_MIN_REQUIRED < MAC_OS_VERSION_10_12
+# error "Running on Mac OSX 10.11 or earlier"
+# endif
+# endif
+#endif
+], [],
+ [on_macos_pre_10_12=no ; AC_MSG_RESULT([no])],
+ [on_macos_pre_10_12=yes; AC_MSG_RESULT([yes])])
+
+if test "$on_macos_pre_10_12" = "no"; then
+ AC_CHECK_FUNCS(
+ clock_gettime \
+ getentropy \
+ )
+fi
+
if test "$bwin32" != "true"; then
AC_CHECK_HEADERS(pthread.h)
AC_CHECK_FUNCS(pthread_create)