aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-01-16 13:35:52 -0500
committerNick Mathewson <nickm@torproject.org>2018-01-16 13:35:52 -0500
commit0cb89eb828005ccf4b1ae72988b9c3b958ceade4 (patch)
tree54d87b5efa6dd8903b996699385aa2d4fb236b5e /configure.ac
parentdb5aa54a422cd45b690293a0c618e6275e1c3608 (diff)
parent2ac9734bd21f3eecb20560cde5c4037230029157 (diff)
downloadtor-0cb89eb828005ccf4b1ae72988b9c3b958ceade4.tar.gz
tor-0cb89eb828005ccf4b1ae72988b9c3b958ceade4.zip
Merge remote-tracking branch 'public/bug24652_032' into maint-0.3.2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8de4774f29..0fdb84c131 100644
--- a/configure.ac
+++ b/configure.ac
@@ -436,6 +436,15 @@ if test "x$enable_rust" = "xyes"; then
fi
fi
+ dnl This is a workaround for #46797
+ dnl (a.k.a https://github.com/rust-lang/rust/issues/46797 ). Once the
+ dnl upstream bug is fixed, we can remove this workaround.
+ case "$host_os" in
+ darwin*)
+ TOR_RUST_EXTRA_LIBS="-lresolv"
+ ;;
+ esac
+
dnl For now both MSVC and MinGW rust libraries will output static libs with
dnl the MSVC naming convention.
if test "$bwin32" = "true"; then
@@ -460,6 +469,8 @@ if test "x$enable_rust" = "xyes"; then
fi
fi
+AC_SUBST(TOR_RUST_EXTRA_LIBS)
+
AC_SEARCH_LIBS(socket, [socket network])
AC_SEARCH_LIBS(gethostbyname, [nsl])
AC_SEARCH_LIBS(dlopen, [dl])