aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-01-16 13:36:48 -0500
committerNick Mathewson <nickm@torproject.org>2018-01-16 13:36:48 -0500
commitf470756cf4660bd7d5e9d4c8d66a56adfd3b7ff7 (patch)
treeb514a0472cbaf3b926de973f034b015ff3a66898 /configure.ac
parent01adeb2471360f4c832252d8b9b9a05ab212a76c (diff)
parent0cb89eb828005ccf4b1ae72988b9c3b958ceade4 (diff)
downloadtor-f470756cf4660bd7d5e9d4c8d66a56adfd3b7ff7.tar.gz
tor-f470756cf4660bd7d5e9d4c8d66a56adfd3b7ff7.zip
Merge branch 'maint-0.3.2'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e471f8f914..9bb09b2dfa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -456,6 +456,15 @@ if test "x$enable_rust" = "xyes"; then
fi
fi
+ dnl This is a workaround for #46797
+ dnl (a.k.a https://github.com/rust-lang/rust/issues/46797 ). Once the
+ dnl upstream bug is fixed, we can remove this workaround.
+ case "$host_os" in
+ darwin*)
+ TOR_RUST_EXTRA_LIBS="-lresolv"
+ ;;
+ esac
+
dnl For now both MSVC and MinGW rust libraries will output static libs with
dnl the MSVC naming convention.
if test "$bwin32" = "true"; then
@@ -482,6 +491,8 @@ if test "x$enable_rust" = "xyes"; then
AC_MSG_RESULT([$RUSTC_VERSION])
fi
+AC_SUBST(TOR_RUST_EXTRA_LIBS)
+
AC_SEARCH_LIBS(socket, [socket network])
AC_SEARCH_LIBS(gethostbyname, [nsl])
AC_SEARCH_LIBS(dlopen, [dl])