aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-08-03 07:38:47 -0400
committerNick Mathewson <nickm@torproject.org>2018-08-03 07:38:47 -0400
commit5597ddc36047a4f306a6f668235d02c069db991a (patch)
tree6288508723859937ee109fdb0456a0c976e13af2 /configure.ac
parentbb1f29423263d2285e318ff190c3692b9d41b6ff (diff)
downloadtor-5597ddc36047a4f306a6f668235d02c069db991a.tar.gz
tor-5597ddc36047a4f306a6f668235d02c069db991a.zip
Mark openbsd-malloc as deprecated
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ea19e3fef8..fbe0fa5ec4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,7 +22,7 @@ AC_CANONICAL_HOST
PKG_PROG_PKG_CONFIG
AC_ARG_ENABLE(openbsd-malloc,
- AS_HELP_STRING(--enable-openbsd-malloc, [use malloc code from OpenBSD. Linux only]))
+ AS_HELP_STRING(--enable-openbsd-malloc, [use malloc code from OpenBSD. Linux only. Deprecated: see --with-malloc]))
AC_ARG_ENABLE(static-openssl,
AS_HELP_STRING(--enable-static-openssl, [link against a static openssl library. Requires --with-openssl-dir]))
AC_ARG_ENABLE(static-libevent,
@@ -1788,7 +1788,7 @@ if test "$tor_cv_uint8_uchar" = "no"; then
fi
AC_ARG_WITH(tcmalloc,
-AS_HELP_STRING(--with-tcmalloc, [use tcmalloc memory allocation library]),
+AS_HELP_STRING(--with-tcmalloc, [use tcmalloc memory allocation library. Deprecated; see --with-malloc]),
[ tcmalloc=yes ], [ tcmalloc=no ])
default_malloc=system
@@ -1839,6 +1839,7 @@ AS_CASE([$malloc],
],
[openbsd], [
+ AC_WARN([The openbsd malloc port is deprecated in Tor 0.3.5 and will be removed in a future version.])
enable_openbsd_malloc=yes
],