aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-03-30 08:53:58 -0400
committerNick Mathewson <nickm@torproject.org>2018-04-05 08:20:07 -0400
commite3ad4957a8d06716d3e5dad9cda09ce236b941d1 (patch)
treefa83e15e998a555eeb1a93cc8da6e8278176fe2c /configure.ac
parent6aaafb0672ec7d2f454720ea0bed41fb91d9744e (diff)
downloadtor-e3ad4957a8d06716d3e5dad9cda09ce236b941d1.tar.gz
tor-e3ad4957a8d06716d3e5dad9cda09ce236b941d1.zip
Fix the default for TOR_RUST_DEPENDENCIES
By default, we want to look at the crates directory of the submodule, not the toplevel of the submodule. Fixes bug 25679; bugfix on 0.3.3.1-alpha.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 2045e0d5f1..143044956f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -440,23 +440,23 @@ if test "x$enable_rust" = "xyes"; then
AC_MSG_CHECKING([rust crate dependencies])
AC_ARG_VAR([TOR_RUST_DEPENDENCIES], [path to directory with local crate mirror])
if test "x$TOR_RUST_DEPENDENCIES" = "x"; then
- TOR_RUST_DEPENDENCIES="$srcdir/src/ext/rust/"
- NEED_MOD=1
+ TOR_RUST_DEPENDENCIES="${srcdir}/src/ext/rust/crates"
fi
+ dnl Check whether the path exists before we try to cd into it.
if test ! -d "$TOR_RUST_DEPENDENCIES"; then
AC_MSG_ERROR([Rust dependency directory $TOR_RUST_DEPENDENCIES does not exist. Specify a dependency directory using the TOR_RUST_DEPENDENCIES variable or allow cargo to fetch crates using --enable-cargo-online-mode.])
ERRORED=1
fi
+ dnl Make the path absolute, since we'll be using it from within a
+ dnl subdirectory.
+ TOR_RUST_DEPENDENCIES=$(cd "$TOR_RUST_DEPENDENCIES" ; pwd)
+
for dep in $rust_crates; do
if test ! -d "$TOR_RUST_DEPENDENCIES"/"$dep"; then
AC_MSG_ERROR([Failure to find rust dependency $TOR_RUST_DEPENDENCIES/$dep. Specify a dependency directory using the TOR_RUST_DEPENDENCIES variable or allow cargo to fetch crates using --enable-cargo-online-mode.])
ERRORED=1
fi
done
- if test "x$NEED_MOD" = "x1"; then
- dnl When looking for dependencies from cargo, pick right directory
- TOR_RUST_DEPENDENCIES="../../src/ext/rust"
- fi
if test "x$ERRORED" = "x"; then
AC_MSG_RESULT([yes])
fi