aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-08-03 07:33:45 -0400
committerNick Mathewson <nickm@torproject.org>2018-08-03 07:33:45 -0400
commitbe8e56c231755069fae03eb13a4ddd9fba4f6563 (patch)
treed4bd238d14e99927b2a4889434dddb4df3cbe794 /configure.ac
parent861d690018c213ad017fbf8dc99d4790c111c396 (diff)
parent2a6c1585b0f13e03eb7e8b8977d56a5cea8b4ce8 (diff)
downloadtor-be8e56c231755069fae03eb13a4ddd9fba4f6563.tar.gz
tor-be8e56c231755069fae03eb13a4ddd9fba4f6563.zip
Merge branch 'maint-0.3.3' into maint-0.3.4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4f5d8337ee..af68e3a095 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1850,6 +1850,10 @@ fi
if test "$using_custom_malloc" = "no"; then
AC_CHECK_FUNCS(mallinfo)
fi
+if test "$using_custom_malloc" = "yes"; then
+ # Tell the C compiler not to use the system allocator functions.
+ TOR_CHECK_CFLAGS([-fno-builtin-malloc -fno-builtin-realloc -fno-builtin-calloc -fno-builtin-free])
+fi
# By default, we're going to assume we don't have mlockall()
# bionic and other platforms have various broken mlockall subsystems.