aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIsis Lovecruft <isis@torproject.org>2018-04-21 01:01:04 +0000
committerIsis Lovecruft <isis@torproject.org>2018-05-08 21:03:37 +0000
commitaf182d4ab51d6a1a70559bbdcd4ab842aa855684 (patch)
treea39ec19013bdb85e4ad9aef1dd001747446923f2 /configure.ac
parent3df37d7b6be4f7d6ece0cd12812595d5f91ea72f (diff)
downloadtor-af182d4ab51d6a1a70559bbdcd4ab842aa855684.tar.gz
tor-af182d4ab51d6a1a70559bbdcd4ab842aa855684.zip
rust: Add crypto crate and implement Rust wrappers for SHA2 code.
* FIXES #24659: https://bugs.torproject.org/24659
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 387fc6fbeb..3bf436203f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -306,7 +306,10 @@ fi
AM_CONDITIONAL(USEPYTHON, [test "x$PYTHON" != "x"])
dnl List all external rust crates we depend on here. Include the version
-rust_crates="libc-0.2.39"
+rust_crates=" \
+ digest-0.7.2 \
+ libc-0.2.39 \
+"
AC_SUBST(rust_crates)
ifdef([AC_C_FLEXIBLE_ARRAY_MEMBER], [