aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-06-26 09:21:55 -0400
committerNick Mathewson <nickm@torproject.org>2018-06-26 09:21:55 -0400
commitfcd26af7c0b9926f8e56149a72de9dd47ad37a69 (patch)
tree2ed5e1ca3044ec1d5b8c03b0de91e58a68aacee0 /configure.ac
parentdd69e74e3f0f25f76107f9ef0aaacbea85271316 (diff)
parent47ee7978fe73816bf15cb392d0e89301f65724f8 (diff)
downloadtor-fcd26af7c0b9926f8e56149a72de9dd47ad37a69.tar.gz
tor-fcd26af7c0b9926f8e56149a72de9dd47ad37a69.zip
Merge branch 'feature26372_029' into maint-0.2.9
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 15ecbe60e1..279660d9b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -213,7 +213,11 @@ AM_PROG_CC_C_O
AC_PROG_CC_C99
AC_ARG_VAR([PYTHON], [path to Python binary])
-AC_CHECK_PROGS(PYTHON, [python python2 python2.7 python3 python3.3])
+AC_CHECK_PROGS(PYTHON, [ \
+ python3 \
+ python3.8 python3.7 python3.6 python3.5 python3.4 \
+ python \
+ python2 python2.7])
if test "x$PYTHON" = "x"; then
AC_MSG_WARN([Python unavailable; some tests will not be run.])
fi