aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2017-12-12 09:18:52 -0500
committerNick Mathewson <nickm@torproject.org>2017-12-12 09:18:52 -0500
commit6c5a73f87abc6a8791e41e9d7f3728d67145001c (patch)
tree4e60b224a45bd5ee372a96b6b9e2fd78802d8b31 /configure.ac
parent21ee765df0a2f20b6de21af0f4e10dc80d6fd68b (diff)
parentcbc465a3d1496d43c9bf28cfaf20d7409a2070b7 (diff)
downloadtor-6c5a73f87abc6a8791e41e9d7f3728d67145001c.tar.gz
tor-6c5a73f87abc6a8791e41e9d7f3728d67145001c.zip
Merge remote-tracking branch 'ahf-oniongit/bugs/24362'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 289f07d1c9..4a6dc80a90 100644
--- a/configure.ac
+++ b/configure.ac
@@ -204,6 +204,20 @@ if test x$enable_event_tracing_debug = xyes; then
AC_DEFINE([TOR_EVENT_TRACING_ENABLED], [1], [Compile the event tracing instrumentation])
fi
+dnl Enable Android only features.
+AC_ARG_ENABLE(android,
+ AS_HELP_STRING(--enable-android, [build with Android features enabled]))
+AM_CONDITIONAL([USE_ANDROID], [test "x$enable_android" = "xyes"])
+
+if test "x$enable_android" = "xyes"; then
+ AC_DEFINE([USE_ANDROID], [1], [Compile with Android specific features enabled])
+
+ dnl Check if the Android log library is available.
+ AC_CHECK_HEADERS([android/log.h])
+ AC_SEARCH_LIBS(__android_log_write, [log])
+
+fi
+
dnl check for the correct "ar" when cross-compiling.
dnl (AM_PROG_AR was new in automake 1.11.2, which we do not yet require,
dnl so kludge up a replacement for the case where it isn't there yet.)