aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-01-04 14:02:24 -0500
committerNick Mathewson <nickm@torproject.org>2018-01-04 14:02:24 -0500
commit2ac9734bd21f3eecb20560cde5c4037230029157 (patch)
treed89b2f263a5286cd188564f7bdb27ee973b59776 /configure.ac
parent9ef97a268b06fed7b07908823600911a2a6eadc1 (diff)
downloadtor-2ac9734bd21f3eecb20560cde5c4037230029157.tar.gz
tor-2ac9734bd21f3eecb20560cde5c4037230029157.zip
Use -lresolv in LIBS with rust on OSX.
This fixes issue #24652, and is a workaround for Rust issue https://github.com/rust-lang/rust/issues/46797 .
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1bd782eb80..6bfbc23268 100644
--- a/configure.ac
+++ b/configure.ac
@@ -436,6 +436,15 @@ if test "x$enable_rust" = "xyes"; then
fi
fi
+ dnl This is a workaround for #46797
+ dnl (a.k.a https://github.com/rust-lang/rust/issues/46797 ). Once the
+ dnl upstream bug is fixed, we can remove this workaround.
+ case "$host_os" in
+ darwin*)
+ TOR_RUST_EXTRA_LIBS="-lresolv"
+ ;;
+ esac
+
dnl For now both MSVC and MinGW rust libraries will output static libs with
dnl the MSVC naming convention.
if test "$bwin32" = "true"; then
@@ -460,6 +469,8 @@ if test "x$enable_rust" = "xyes"; then
fi
fi
+AC_SUBST(TOR_RUST_EXTRA_LIBS)
+
AC_SEARCH_LIBS(socket, [socket network])
AC_SEARCH_LIBS(gethostbyname, [nsl])
AC_SEARCH_LIBS(dlopen, [dl])