aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-08-03 07:33:45 -0400
committerNick Mathewson <nickm@torproject.org>2018-08-03 07:33:45 -0400
commit2a6c1585b0f13e03eb7e8b8977d56a5cea8b4ce8 (patch)
tree73d26e386ba31a172d7cc1cdbc53068e71bb8178 /configure.ac
parenteb604f5faaa588cf6bf0cc81dc5f2a3b9e9f9e4f (diff)
parent4856a6e6c4b352f04b98f7f77c70a0c33dc8c29c (diff)
downloadtor-2a6c1585b0f13e03eb7e8b8977d56a5cea8b4ce8.tar.gz
tor-2a6c1585b0f13e03eb7e8b8977d56a5cea8b4ce8.zip
Merge branch 'maint-0.3.2' into maint-0.3.3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b71d648f15..cd591c785f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1724,6 +1724,10 @@ fi
if test "$using_custom_malloc" = "no"; then
AC_CHECK_FUNCS(mallinfo)
fi
+if test "$using_custom_malloc" = "yes"; then
+ # Tell the C compiler not to use the system allocator functions.
+ TOR_CHECK_CFLAGS([-fno-builtin-malloc -fno-builtin-realloc -fno-builtin-calloc -fno-builtin-free])
+fi
# By default, we're going to assume we don't have mlockall()
# bionic and other platforms have various broken mlockall subsystems.