aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrubiate <cb@viennan.net>2017-02-02 00:10:46 +1300
committerNick Mathewson <nickm@torproject.org>2017-02-01 10:30:49 -0500
commite9ec818c28c96ba1ca6f40c9ccc84c900a5b7265 (patch)
tree39993b8ba79f54444ec778775cbeeab8a2670371 /configure.ac
parent0d4d9b6d889de6dc85ca8870ada123aaf41b0053 (diff)
downloadtor-e9ec818c28c96ba1ca6f40c9ccc84c900a5b7265.tar.gz
tor-e9ec818c28c96ba1ca6f40c9ccc84c900a5b7265.zip
Support LibreSSL with opaque structures
Determining if OpenSSL structures are opaque now uses an autoconf check instead of comparing the version number. Some definitions have been moved to their own check as assumptions which were true for OpenSSL with opaque structures did not hold for LibreSSL. Closes ticket 21359.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2134a41d3f..f7bdd97e13 100644
--- a/configure.ac
+++ b/configure.ac
@@ -677,6 +677,11 @@ AC_CHECK_FUNCS([ \
dnl Check if OpenSSL has scrypt implementation.
AC_CHECK_FUNCS([ EVP_PBE_scrypt ])
+dnl Check if OpenSSL structures are opaque
+AC_CHECK_MEMBERS([SSL.state], , ,
+[#include <openssl/ssl.h>
+])
+
LIBS="$save_LIBS"
LDFLAGS="$save_LDFLAGS"
CPPFLAGS="$save_CPPFLAGS"