aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorcypherpunks <cypherpunks@torproject.org>2016-12-15 16:15:42 +0000
committerNick Mathewson <nickm@torproject.org>2016-12-23 10:35:22 -0500
commita1c0ebc3ebc49924fa38dd4f60d89204208aacc8 (patch)
tree1453b2dd0b8ea9488813dd756f69da22775767e5 /configure.ac
parentdee0b869c9393ba2b0d84527be4ed606f320a236 (diff)
downloadtor-a1c0ebc3ebc49924fa38dd4f60d89204208aacc8.tar.gz
tor-a1c0ebc3ebc49924fa38dd4f60d89204208aacc8.zip
Use AM_PROG_AR to improve portability
Turning on warnings in Automake makes it complain about not using the AM_PROG_AR macro. The AM_PROG_AR macro is required when LIBRARIES or LTLIBRARIES is used. The macro looks for an archiver and wraps it in the ar-lib script which is automatically generated so Git should ignore it. It makes the custom check for 'ar' obsolete so it is removed. The AM_PROG_AR macro was added in Automake 1.11.2 thus the minimum Automake version is increased.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 130ec0964d..44f7fe675c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -171,10 +171,7 @@ AC_ARG_ENABLE(libscrypt,
AS_HELP_STRING(--disable-libscrypt, [do not attempt to use libscrypt]))
dnl check for the correct "ar" when cross-compiling
-AN_MAKEVAR([AR], [AC_PROG_AR])
-AN_PROGRAM([ar], [AC_PROG_AR])
-AC_DEFUN([AC_PROG_AR], [AC_CHECK_TOOL([AR], [ar], [ar])])
-AC_PROG_AR
+AM_PROG_AR
dnl Check whether the above macro has settled for a simply named tool even
dnl though we're cross compiling. We must do this before running AC_PROG_CC,