aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2015-03-18 14:27:00 -0400
committerNick Mathewson <nickm@torproject.org>2015-03-18 14:27:00 -0400
commit54d6e5e71e604ffedcb3c0a2aeff4b39bc9e37db (patch)
treedc45202d8c3b636fd84abef68b28f252234fe01e /configure.ac
parent9bdce9d4e5fd164b05e1ae87ab0f629d2cd38e42 (diff)
parent21fd94ddb81327a339a942fb5d134cb6ebb5a998 (diff)
downloadtor-54d6e5e71e604ffedcb3c0a2aeff4b39bc9e37db.tar.gz
tor-54d6e5e71e604ffedcb3c0a2aeff4b39bc9e37db.zip
Merge remote-tracking branch 'public/feature15053'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 143cb722fa..610a431129 100644
--- a/configure.ac
+++ b/configure.ac
@@ -215,6 +215,8 @@ AC_PROG_CPP
AC_PROG_MAKE_SET
AC_PROG_RANLIB
+AC_PATH_PROG([PERL], [perl])
+
dnl autoconf 2.59 appears not to support AC_PROG_SED
AC_CHECK_PROG([SED],[sed],[sed],[/bin/false])
@@ -1661,6 +1663,8 @@ AC_CONFIG_FILES([
contrib/dist/tor.service
src/config/torrc.sample
src/config/torrc.minimal
+ scripts/maint/checkOptionDocs.pl
+ scripts/maint/updateVersions.pl
])
if test x$asciidoc = xtrue && test "$ASCIIDOC" = "none" ; then
@@ -1682,7 +1686,3 @@ if test x$asciidoc = xtrue && test "$ASCIIDOC" = "none" ; then
fi
AC_OUTPUT
-
-if test -x /usr/bin/perl && test -x ./scripts/maint/updateVersions.pl ; then
- ./scripts/maint/updateVersions.pl
-fi