aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYawning Angel <yawning@schwanenlied.me>2015-06-02 18:58:57 +0000
committerNick Mathewson <nickm@torproject.org>2015-06-02 15:04:20 -0400
commit8024f6a75f00044fd342323d26e9907fc571c283 (patch)
tree67fcb2652d436aac2ec24349aebd9a9b4f1553d0 /configure.ac
parentff835e23280c0f29ca9ab25bfc3069276c0b8ab6 (diff)
downloadtor-8024f6a75f00044fd342323d26e9907fc571c283.tar.gz
tor-8024f6a75f00044fd342323d26e9907fc571c283.zip
A few more minor OpenSSL 1.1 fixes.
* Use `TLS_method()` instead of the deprecated `SSLv23_method()` * Fix one missed conversion to `SSL_CIPHER_get_id()`
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ab96c20f3f..b8ca188a87 100644
--- a/configure.ac
+++ b/configure.ac
@@ -640,6 +640,7 @@ AC_CHECK_FUNCS([ \
SSL_get_client_ciphers \
SSL_get_client_random \
SSL_CIPHER_find \
+ TLS_method
])
LIBS="$save_LIBS"
LDFLAGS="$save_LDFLAGS"