aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorteor <teor@torproject.org>2019-10-18 17:16:32 +1000
committerteor <teor@torproject.org>2019-10-18 17:16:32 +1000
commit4442eef0b3d308008992ae71fcd78ba52f305cd7 (patch)
tree41dc1937d0f2537d648898acdf0ed6fef8de2955 /configure.ac
parentf59c4a094090e0c5cfe4c5a7aa3ffdc357fc95f0 (diff)
downloadtor-4442eef0b3d308008992ae71fcd78ba52f305cd7.tar.gz
tor-4442eef0b3d308008992ae71fcd78ba52f305cd7.zip
configure: Interpret --with-tcmalloc=no correctly
Fixes bug 32124; bugfix on 0.2.0.20-rc.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 11d49df458..da74042dc8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1894,8 +1894,7 @@ if test "$tor_cv_uint8_uchar" = "no"; then
fi
AC_ARG_WITH(tcmalloc,
-AS_HELP_STRING(--with-tcmalloc, [use tcmalloc memory allocation library. Deprecated; see --with-malloc]),
-[ tcmalloc=yes ], [ tcmalloc=no ])
+AS_HELP_STRING(--with-tcmalloc, [use tcmalloc memory allocation library. Deprecated; see --with-malloc]))
default_malloc=system
@@ -1904,7 +1903,7 @@ if test "x$enable_openbsd_malloc" = "xyes" ; then
default_malloc=openbsd
fi
-if test "x$tcmalloc" = "xyes"; then
+if test "x$with_tcmalloc" = "xyes"; then
AC_MSG_NOTICE([The --with-tcmalloc argument is deprecated; use --with-malloc=tcmalloc instead.])
default_malloc=tcmalloc
fi