aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-04-05 08:21:43 -0400
committerNick Mathewson <nickm@torproject.org>2018-04-05 08:21:43 -0400
commit43f31555827319077858fb3872c28764961b944a (patch)
treeae0c8461952c63ead8cb48d18f26e7219d182e84 /configure.ac
parent52846f728d92b44cda1a7cab1bfa53b2450a29b9 (diff)
parentac3e389dbd7224a23dfa12da7a15b748feb88435 (diff)
downloadtor-43f31555827319077858fb3872c28764961b944a.tar.gz
tor-43f31555827319077858fb3872c28764961b944a.zip
Merge branch 'maint-0.3.3'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 83760165ed..878f5a88bb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -446,23 +446,23 @@ if test "x$enable_rust" = "xyes"; then
AC_MSG_CHECKING([rust crate dependencies])
AC_ARG_VAR([TOR_RUST_DEPENDENCIES], [path to directory with local crate mirror])
if test "x$TOR_RUST_DEPENDENCIES" = "x"; then
- TOR_RUST_DEPENDENCIES="$srcdir/src/ext/rust/"
- NEED_MOD=1
+ TOR_RUST_DEPENDENCIES="${srcdir}/src/ext/rust/crates"
fi
+ dnl Check whether the path exists before we try to cd into it.
if test ! -d "$TOR_RUST_DEPENDENCIES"; then
AC_MSG_ERROR([Rust dependency directory $TOR_RUST_DEPENDENCIES does not exist. Specify a dependency directory using the TOR_RUST_DEPENDENCIES variable or allow cargo to fetch crates using --enable-cargo-online-mode.])
ERRORED=1
fi
+ dnl Make the path absolute, since we'll be using it from within a
+ dnl subdirectory.
+ TOR_RUST_DEPENDENCIES=$(cd "$TOR_RUST_DEPENDENCIES" ; pwd)
+
for dep in $rust_crates; do
if test ! -d "$TOR_RUST_DEPENDENCIES"/"$dep"; then
AC_MSG_ERROR([Failure to find rust dependency $TOR_RUST_DEPENDENCIES/$dep. Specify a dependency directory using the TOR_RUST_DEPENDENCIES variable or allow cargo to fetch crates using --enable-cargo-online-mode.])
ERRORED=1
fi
done
- if test "x$NEED_MOD" = "x1"; then
- dnl When looking for dependencies from cargo, pick right directory
- TOR_RUST_DEPENDENCIES="../../src/ext/rust"
- fi
if test "x$ERRORED" = "x"; then
AC_MSG_RESULT([yes])
fi