aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Hahn <sebastian@torproject.org>2019-08-18 21:31:09 +0200
committerSebastian Hahn <sebastian@torproject.org>2019-08-20 07:16:46 +0200
commit360a29e282a546c47ad1346bb035ffb01fe11c0d (patch)
treef8f70aa04b3cf1d47eee4190e99d8a5f85468395 /configure.ac
parent36a27fa2d331c53802635431849ca9a400122a4e (diff)
downloadtor-360a29e282a546c47ad1346bb035ffb01fe11c0d.tar.gz
tor-360a29e282a546c47ad1346bb035ffb01fe11c0d.zip
Rust: Update version requirements and CI
The #[global_allocator] attribute is not available in versions prior to 1.28.0, the default-linker-libraries feature requires rust 1.31.0. Adapt the CI to prevent accidental increases in Rust version by testing against 1.31.0, beta and nightly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9ec123f51e..f90a0c09b1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -558,8 +558,8 @@ if test "x$enable_rust" = "xyes"; then
if test "x$RUSTC_VERSION_MAJOR" = "x" -o "x$RUSTC_VERSION_MINOR" = "x"; then
AC_MSG_ERROR([rustc version couldn't be identified])
fi
- if test "$RUSTC_VERSION_MAJOR" -lt 2 -a "$RUSTC_VERSION_MINOR" -lt 14; then
- AC_MSG_ERROR([rustc must be at least version 1.14])
+ if test "$RUSTC_VERSION_MAJOR" -lt 2 -a "$RUSTC_VERSION_MINOR" -lt 31; then
+ AC_MSG_ERROR([rustc must be at least version 1.31.0])
fi
AC_MSG_RESULT([$RUSTC_VERSION])
fi