aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2019-03-13 10:37:37 -0400
committerNick Mathewson <nickm@torproject.org>2019-03-13 10:37:37 -0400
commitcab93930de8888981af63f157f71721ac233db34 (patch)
treeab2844d3f72bca85adcdc5b203ce3f7d55c3ebc1 /configure.ac
parent26b0d95397987a4458cc8afc4142b70f9f797870 (diff)
parent8b64ff7a3f2d9eb0837248a6c9b0e8b438374369 (diff)
downloadtor-cab93930de8888981af63f157f71721ac233db34.tar.gz
tor-cab93930de8888981af63f157f71721ac233db34.zip
Merge branch 'pr_722_squashed'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 14147eef77..78597e511d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1210,6 +1210,11 @@ if test "$fragile_hardening" = "yes"; then
AC_MSG_ERROR([The compiler supports -fsanitize=undefined, but for some reason I was not able to link when using it. Are you missing run-time support? With GCC you need libasan.*, and with Clang you need libclang_rt.ubsan*])
fi
+ TOR_TRY_COMPILE_WITH_CFLAGS([-fno-sanitize=float-divide-by-zero], also_link, CFLAGS_UBSAN="-fno-sanitize=float-divide-by-zero", true)
+ if test "$tor_cv_cflags__fno_sanitize_float_divide_by_zero" = "yes" && test "$tor_can_link__fno_sanitize_float_divide_by_zero" != "yes"; then
+ AC_MSG_ERROR([The compiler supports -fno-sanitize=float-divide-by-zero, but for some reason I was not able to link when using it. Are you missing run-time support? With GCC you need libasan.*, and with Clang you need libclang_rt.ubsan*])
+ fi
+
TOR_CHECK_CFLAGS([-fno-omit-frame-pointer])
fi