aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2019-02-05 16:58:56 -0500
committerNick Mathewson <nickm@torproject.org>2019-02-06 22:03:30 -0500
commit8ca808f81d28bbae9e9059172a7b7479d20e9594 (patch)
treefa9eb7ccf4db3015134db06cfadc48d72621e670 /configure.ac
parentbfd1d702433fde0c551a1c79d410d87fe22feb30 (diff)
downloadtor-8ca808f81d28bbae9e9059172a7b7479d20e9594.tar.gz
tor-8ca808f81d28bbae9e9059172a7b7479d20e9594.zip
Code for anonymous mappings via mmap() or CreateFileMapping().
Using an anonymous mmap() is a good way to get pages that we can set kernel-level flags on, like minherit() or madvise() or mlock(). We're going to use that so that we can make uninheritable locked pages to store PRNG data.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 75bb0c7bd9..7de3c3a46e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -605,8 +605,10 @@ AC_CHECK_FUNCS(
llround \
localtime_r \
lround \
+ madvise \
memmem \
memset_s \
+ minherit \
mmap \
pipe \
pipe2 \
@@ -1450,6 +1452,7 @@ AC_CHECK_HEADERS([errno.h \
inttypes.h \
limits.h \
linux/types.h \
+ mach/vm_inherit.h \
machine/limits.h \
malloc.h \
malloc/malloc.h \